Pre-provision BitLocker fails with Invalid command line argument ‘/full’

Do you you suddenly get this error during OSD after upgrading to SCCM 1806?

 

In the SMSTS log, the error looks like this:

==============================[ OSDOfflineBitlocker.exe ]==============================
Command line: “OSDOfflineBitlocker.exe” /enable /drive:C: /ignoretpm:True /full:False
Initialized COM
Command line for extension .exe is “%1″ %*
Set command line:”OSDOfflineBitlocker.exe” /enable /drive:C: /ignoretpm:True /full:False
FALSE, HRESULT=80070057 (main.cpp,372)
ProcessCommandLine(argInfo), HRESULT=80070057 (main.cpp,418)
Invalid command line argument ‘/full’

 

This is caused by an update to the Pre-provision BitLocker step in SCCM 1806. Now you can select between “Used space only” and “Full disk” when encrypting the volume. Previously, the default value was “Used space only” and couldn’t be changed in the task seqence step.

 

The “Enable BitLocker” step also has this new option in SCCM 1806.

Solution:

To solve this problem and support this new SCCM feature, you simply need to update the boot image(s) on your distribution point(s).

 

Explanation:

The BitLocker executables used by SCCM are loaded into the boot image and can be found here during WinPE: X:\SMS\BIN\x64\

As you can see, the OSDOfflineBitlocker.exe has changed after I updated the boot image.

Before:

After:

6 Comments

Join the discussion and tell us your opinion.

robmoreply
2018-11-27 at 23:48

This solution worked for me. Thank you very much for posting this!

windowstechreply
2018-11-28 at 13:02
– In reply to: robmo

Welcome 🙂

Marosreply
2018-12-11 at 15:38

Excellent article. Update DP solved my issue. Thanks a lot.

windowstechreply
2018-12-11 at 15:59
– In reply to: Maros

Glad I could help

Davidreply
2019-01-30 at 22:47

I updated the boot images on all my DPs but I seem to still be running into the same error. I even went as far as uninstalling and reinstalling the latest version of Windows ADK (1809) and then selected “Update Distribution Points” and checked the box to “Reload this boot image with the current Windows PE version from the Windows ADK” and I still receive the same error. Any ideas by chance?

windowstechreply
2019-01-30 at 23:37
– In reply to: David

Hi David
Are you PxE booting?
What errors do you get in the smsts.log?

Leave a reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.